PA-DSS Compliance – What it means for Miva Merchant Store Owners

As online store owners should know, July 1, 2010 was the required deadline for all payment applications to become PA-DSS Validated. This affects all payment gateway providers, swipe terminals and shopping card vendors, including Miva Merchant.

Miva Merchant PA-DSS Validated

PA-DSS Validation is different from PCI-DSS Compliance. Both are implemented and governed by the PCI Security Council, but in order to maintain your PCI-DSS Compliance as a merchant, you must be running PA-DSS Validated shopping cart software.

Miva Merchant 5.5

Miva Merchant 5.5 store owners can feel comfort in knowing that their shopping cart has been PA-DSS Validated. The challenge remains for Miva 4.x owners because Miva Merchant will not and has no plans to validate the older versions of Miva Merchant.

Those 4.x merchants should consider upgrading their store. BZA can assist merchants with the process. To encourage store owners to upgrade, Miva Merchant is offering a free Miva Merchant 5.5 upgrade to qualified Miva Merchant 4.x license owners. For more information or to see if you qualify please contact us.

This entry was posted in Ecommerce. Bookmark the permalink.